System Outage
Incident Report for Payrexx
Resolved
The incident has been resolved.
Posted 3 months ago. May 20, 2019 - 15:26 UTC
Monitoring
The problem has been resolved and we are monitoring the systems.
Posted 3 months ago. May 20, 2019 - 15:11 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. May 20, 2019 - 14:57 UTC
This incident affected: Payment Platform (Servers).