Payrexx Direct Payment Outage
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 13:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2020 - 13:24 UTC
This incident affected: Payment Platform (Payrexx Payment).