Telephone Service not available
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 14:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2022 - 14:25 UTC
Investigating
We are currently facing difficulties receiving customer calls and are continuing to investigate the issue.
Posted Nov 16, 2022 - 13:29 UTC
This incident affected: Helpdesk (Support Platform (support.payrexx.com)) and Websites (Website (www.payrexx.com)).