Elevated errors with Mastercard 3D Secure
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 16:13 UTC
Investigating
We’re reaching out to inform you that Payrexx is experiencing an elevated rate of errors related to Mastercard 3D Secure with the payment provider Payrexx Direct.
We are currently investigating and we will get back to you with an update as soon as possible.
Posted Jan 17, 2023 - 15:27 UTC
This incident affected: Payment Platform (Payrexx Payment).