Problem With Our Bank Reconciliation since Friday January 23rd.

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 11:06 UTC

Identified

We are currently experiencing technical difficulties affecting transactions since Friday, January 23rd.

Payouts: Payments are currently delayed due to a system status error.

Invoice Payments: Bank transfers (Payment method "Kauf auf Rechnung") received since Friday have not yet been posted to accounts.

Our team is working on a fix. Your funds are safe, and all transactions will be processed automatically as soon as possible. No action is required on your part.
Posted Jan 27, 2026 - 06:31 UTC
This incident affected: Payment Platform (Merchant Backend).