Outstanding Booking of Transaction Fees for Credit Card Payments with Payrexx Swiss Collecting Between March 3, 2022 - March 20, 2022
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 16:17 UTC
Identified
There was an issue booking the transaction fees for transactions made with credit cards with the payment service provider Payrexx Swiss Collecting. Due to this issue, fees for transactions taken place between March 3, 2022 and March 20, 2022 have not been deducted from payouts. We will create adjustments on your balance accordingly in the next two days.
Posted Mar 21, 2022 - 07:17 UTC
This incident affected: Payment Platform (Payrexx Payment).