Increased Error Rates: Credit Card Payments with Payrexx Swiss Collecting
Incident Report for Payrexx
Resolved
The incident has been successfully resolved. It was attributed to an outage in credit card processing, which occurred from 11:30 UTC to 17:24 UTC.
Posted Nov 06, 2023 - 17:34 UTC
Investigating
We encountered increased error rates starting from 11:30 UTC during processing of credit card payments in Payrexx Swiss Collecting. We are still identifying the root cause.
Posted Nov 06, 2023 - 16:40 UTC
This incident affected: Payment Platform (Payrexx Payment).