TWINT Scheme Incidents - TWINT Services are unavailable - 12 Dec 2023
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 06:17 UTC
Investigating
TWINT was aware of technical issues between 09:50 CET and 11:56 CET with the following services and was investigating the issue.

Impacted Services: P2P, P2M
Impact TWINT overall ecosystem: 50%
Posted Dec 12, 2023 - 11:15 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters).