Issues Processing TWINT Transactions
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 11:01 UTC
Monitoring
TWINT payment processing is working again. We're currently monitoring the results.
Posted Nov 02, 2020 - 10:24 UTC
Identified
Since 10:45 CET the TWINT payment processor is experiencing issues. We are unable to process payments for the payment method TWINT. We are in contact with the TWINT team and will keep you updated.
Posted Nov 02, 2020 - 10:17 UTC
This incident affected: Payment Platform (Payment Adapters).