Partial TWINT Onboarding & Payment Outage
Incident Report for Payrexx
Resolved
TWINT has resolved this incident.
Posted Jul 29, 2021 - 09:05 UTC
Investigating
TWINT payments of newly onboarded merchants currently don't work. TWINT is investigating this issue.
Posted Jul 26, 2021 - 12:54 UTC
This incident affected: Payment Platform (Payrexx Payment).