Payrexx Pay - Onboarding TWINT Actually Not Possible

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 09:07 UTC

Identified

TWINT has informed us, that the onboarding for TWINT in Payrexx Pay is at the moment not possible due to a bug. TWINT is currently investigating the case in order to create a bug fix.
Posted Jun 27, 2025 - 12:24 UTC
This incident affected: Payment Platform (Payrexx Payment).