Payment problems with the payment provider PostFinance Pay
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 14:43 UTC
Investigating
A technical error at the financial services provider PostFinance is still causing problems with PostFinance Twint payments and PostFinance Pay.
PostFinance is current investigating the problem.
Posted Nov 04, 2024 - 10:32 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters).