Cloudflare Incident - Still Ongoing

Incident Report for Payrexx

Resolved

Due to a technical issue with the service provider Cloudflare, payments on POS devices were not possible between 11:48 - 14:42 UTC. All services are actually up-to-date and back in operation.
Posted Nov 18, 2025 - 16:52 UTC

Identified

Due to a technical issue with the service provider Cloudflare, there are still problems with payments on POS. The issue persists and will be examined.
Posted Nov 18, 2025 - 13:32 UTC
This incident affected: Payment Platform (POS Terminals (Card Readers)).