Website Performance Issues
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 10:34 UTC
Investigating
We are currently investigating this issue.
Posted Nov 27, 2019 - 07:21 UTC
This incident affected: Websites (Website (www.payrexx.com)).