Delayed Processing of Purchase on Invoice (Bank transfer) Payments
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted May 29, 2024 - 08:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2024 - 09:24 UTC
Investigating
Purchase on invoice payments for invoices created from May 22, 2024, are currently being processed with delays. We are investigating this issue.
Posted May 28, 2024 - 06:16 UTC
This incident affected: Payment Platform (Payrexx Payment).