Payout delay
Incident Report for Payrexx
Resolved
The incident has been resolved. Payouts from yesterday and today have been processed.
Posted May 28, 2024 - 06:45 UTC
Update
We are still working to resolve it as quickly as possible.
Posted May 27, 2024 - 13:39 UTC
Identified
Due to technical changes at our partner bank, there are currently delays with Payrexx Swiss Collecting payouts. We have identified the issue and are working to resolve it as quickly as possible.
Posted May 27, 2024 - 10:05 UTC
This incident affected: Payment Platform (Payrexx Payment).