Payout Status Inaccurate for Payouts on 6. November
Incident Report for Payrexx
Resolved
This incident has been resolved. Payout status has been modified according to the bank transfer status.
Posted Nov 09, 2023 - 11:29 UTC
Investigating
Payouts that have been created on the 6. November may have a wrong status. We are investigating this issue.
Posted Nov 08, 2023 - 16:53 UTC