System Outage
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 08:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 11, 2019 - 07:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 11, 2019 - 07:20 UTC
Investigating
We are currently investigating this issue which has been caused due to maintenance.
Posted Dec 11, 2019 - 07:17 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters, Servers, Databases, Merchant Backend, API, Backoffice Dashboard) and Websites (Apply (signup.payrexx.com)).