Technical Problems with TWINT
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Jan 28, 2021 - 18:34 UTC
Identified
TWINT has technical issues with the payment processing and API servers. The technical issues have been confirmed by TWINT and they are working on a solution. Payments with TWINT may not work or appear in Payrexx delayed.
Posted Jan 28, 2021 - 15:28 UTC
This incident affected: Payment Platform (Payment Adapters).