Delay in Payrexx Pay CHF Payouts (20th & 21st July 2026)

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 08:18 UTC

Investigating

We would like to inform you about a delay regarding Payrexx Pay CHF payouts from 20th and 21st July 2026.

Due to recurring technical issues with the API and connectivity of our payout partner, payouts for these dates are currently delayed or processing slower than usual.

Our payout partner's technical team is actively investigating the issue, and we are closely monitoring the situation. We apologize for the inconvenience and will provide further updates as soon as more information becomes available.
Posted Jul 21, 2026 - 14:05 UTC
This incident affected: Payment Platform (Payrexx Payment).