TWINT Services are partially unavailable
Incident Report for Payrexx
Resolved
We identified an increased error rate while processing payments with TWINT between 09:30 and 12:00 UTC. The situation has normalized.
Posted May 28, 2024 - 14:17 UTC
Investigating
TWINT is currently not available, no payments can be processed via TWINT. We will inform you as soon as we receive more information about this incident from TWINT.
Posted May 28, 2024 - 10:39 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters).