Delay in CHF payouts on 27/08/2025

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 12:46 UTC

Identified

We would like to inform you about a delay in the CHF payouts from yesterday, 27 August 2025.
Some payouts could not be carried out as planned. The error was caused by our payout partner. There was an error during the execution of the payouts and the execution was cancelled.

The technical team of our payout partner is currently investigating this incident. The affected payouts are expected to be resent today.
Posted Aug 28, 2025 - 09:39 UTC
This incident affected: Payment Platform (Payrexx Payment).