Login and Sign Up Problem

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 06:40 UTC

Investigating

Due to today's release, the login and signup page is currently not available. We are working hard to solve the problem and will provide an update as soon as the issue is resolved.
Posted Apr 01, 2025 - 06:15 UTC
This incident affected: Websites (Apply (signup.payrexx.com)).