Payout Delay - Payouts of 7+8. July 2026

Incident Report for Payrexx

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 07:21 UTC

Investigating

We would like to inform you about a delay due to an error in the Payrexx Pay CHF payouts from 7th and 8th July 2026. The error was caused by our payout partner. The technical team of our payout partner is currently investigating this incident.
Posted Jul 08, 2026 - 08:55 UTC
This incident affected: Payment Platform (Merchant Backend).