Technical Problems with PostFinance Card and PostFinance E-Finance
Incident Report for Payrexx
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 04:39 UTC
Identified
We received the information from PostFinance that they are having technical problem with the processing of PostFinance Card and PostFinance E-Finance transactions at the moment.
Posted Mar 16, 2020 - 10:51 UTC
This incident affected: Payment Platform (Payment Adapters).