Payrexx Direct: Apple Pay Not Processing
Incident Report for Payrexx
Resolved
Apple Pay Payments were not available from 04:45 to 11:00 UTC.
Posted Jul 16, 2024 - 10:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2024 - 10:03 UTC