Platform Partially Unavailable

Incident Report for Payrexx

Resolved

The issues causing performance degradation and partial unavailability between 10:29 UTC and 11:04 UTC have been fully resolved.
Posted Dec 23, 2025 - 11:15 UTC

Investigating

Since approximately 11:30 CET we are partially not available. We are currently investigating this issue.
Posted Dec 23, 2025 - 10:48 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters, Servers, Databases, Merchant Backend, API, Backoffice Dashboard, POS Terminals (Card Readers)) and Websites (Apply (signup.payrexx.com)).